PDA

View Full Version : GPS Comms - USB to Serial



Beast Of Bodmin
12th February 2006, 04:56 AM
Hi All,
I recently had to-re-install Win XP and in doing so require to reload the driver for the USB to serial cable that connects to the Meridian. I've lost the disk - bugger!

Does anybody have a link to get a driver for one of these cables?

The cable is made by a mob called 'Prolific'. I'll try their website for downloads first - might just get lucky!

Cheers
BoB

arthurking83
12th February 2006, 06:07 AM
It's most likely the PL2303 chip...if so, then use this (the latest driver I could find)!

I had issues with the driver that came on the disk with the cable :mad:


EDIT: I (re)found the site where I got my updated driver.
So I deleted the file I uploaded!

Prolific PL 2303 USB - Serial driver (http://www.prolific.com.tw/eng/downloads.asp?ID=31)


:)

CJfish
9th March 2006, 08:18 PM
Guys or Girls,

I have tried using a USB to serial cable to connect my eTrex to a PC without any success. I have tried using a couple of different types of cables but no luck. I am using the Garmin Mapsource software, if that helps. Has anyone else experienced these problems or I am just doing something wrong. Any help would be greatly appreciated.

Thanks,

CJ

arthurking83
9th March 2006, 09:26 PM
.......... Has anyone else experienced these problems or I am just doing something wrong.......

Lot's of people have this same problem!



......Any help would be greatly appreciated.


You may be better off posting in the Garmin Forum!!
(maybe someone from the Garmin camp can help with specific Garmin tips!!)

So a brief help from me...
Are you connecting an etrex (with Serial cable) to a PC USB port?
(is your PC too new, that it doesn't have a Serial port around the back?)

If so have you installed the driver that came with the cable(s)?

If so, have you set the COM Ports correctly, in device manager, to the same setup as your GPS?
Device Manager-> Ports (COM & LPT).
If your USB-serial cable is attached, you should see an entry for this device.
It may be called xyz abc123 USB-serial Comm Port (COMx) where x may be something like 4, 5, 6...etc(generally set to higher than 3??)

Right click this device and select properties. Go to the Port settings and make sure you set it up(same baud rate) like your GPS is set!
Be sure to turn on NMEA on your GPS!!!

You can use hyperterminal to see what stuff your GPS is outputtingor just connect it directly to MapSource, and see how you go.....


:confused:
if you're still having trouble, post in the Garmin forums!

CJfish
11th March 2006, 08:21 AM
Arthur,

Thanks for your help. I have tried everything that you have mentioned except the hyperterminal that oyou mentioned. My PC does have a com port in the back and I don't have a problem connecting to it when using it that way. I also have access to a laptop which doesn't have a com port so hence the reason for attempting to connect via a USB adaptor.

I will post on the Garmin forum.

Thanks,

CJ

tes_prize
1st April 2006, 05:18 PM
I have a garmin legend and have successfully linked to the pc via a usb serial adapter. What brand is your cable and version of the usb to serial driver. If needed I can post the driver for my cable to see if that works.

After installing the driver I ran mapsource and using "find device", it located it first time on com 5. I have heard of problems with com port conflicts, but luckly I did not get any.

If you need further info/drivers/assistance I will be glad to help