PDA

View Full Version : broken Tevion GPS Navigator PWM-3501 From the top



douggieg
26th November 2009, 05:05 PM
My Tevion recently came to an error message that I cannot bypass after turning it on or resetting it.


"Application Error
Application MainMenu.exe
encountered a serious error and
must shut down"
This error window will not respond at all to the OK or Exit options.

Tempo might have repaired it out of warranty IF I could produce my original receipt of purchase, but I cannot and was looking at a $50 to $100 fee for a repair.

Back in the early days I could access it's file with my desktop PC via USB running under XP, and might have had a chance of repairing/reprogramming it myself. But now with a Vista laptop, it is not detected when it is plugged into the USB.

My issue is it seem to want to work, but I cannot access its files to reprogram. And I do not want to turf it if the issue is something simple that I cannot see.

Can I access the program files again by unboxing the old desktop, reinstall XP on it and MS sync etc all over again and try to reaccess it there again.

Would I acheive anything doing that if it did access the Tevion files.

Is there some way I can access it with my laptop running Vista, Vista sync and Route66 sync, it wont happen as it stands now with all those programs, drivers etc installed.

Should I just drop this into a :throwpc bucket of water and forget it.

Cheers

Douggie

PS I have read up a few fixes on other thread and trialled setting an ini file onto a flash card...nothing made any difference.

johnhajter
27th November 2009, 05:57 PM
Hi douggieg,
I used to have this one for a few days, I just was testing it, it was only 200MHz processor so I returned it to Aldi and got my money back.
When I was playing with it, I discovered that when you held power button and then reset it it load the blue screen with chinese language, I wasn't surprised at all, and when you pressed menu button the characters on the screen were changing, at some stage I saw usb, then I pressed reset or power again, I think and it loaded and the flash disk was formated and no gps software just one file usb something on it, but there was some forum somwhere, I didn't test if it was connecting to PC because I was in the car at that time, and I had Igo8 on SD card or PolNav.
The best thing, is to get someone who can read chinese.
john
P.S. Maybe it was on/off switch and power combination, not 100% sure, but this is the bootloader an you can hard reset the device fom it. Just search for Tevion and forums, you might find it, the guy there, had the combination from chinese friend, who translated it for him.
So don't worry, I bricked mine and is working again.
You can always recreate rom and flash it if someone from here
will dump the image for you.

douggieg
11th December 2009, 05:53 PM
Right well thanks for that info, my first and main issue is getting communication via USB from the Tevion to my laptop running Vista...nothing happens despite the various rewuired sync programs being installed... I may set up my old desktop with XP again and see if that works as it did 12 months ago...

sdoherty82
19th December 2009, 02:23 PM
Good luck getting this to work with vista. I have the same model and it also recently decided to display a application error and is trying to tell me to reload the initialisation engine. I have vista at home and it won't recognise it at all. i tried reloading the software at work (xp) but no luck. Im still getting the same error. If someone has go this to work on vista, i would love to know how.

johnhajter
19th December 2009, 09:49 PM
it also recently decided to display a application error and is trying to tell me to reload the initialisation engine.
hi guys,
It is telling you to hard reset the device. What does it mean?
It tells you to reload everything from scratch, like reinstalling
the operating system.
I mentioned that above, press and hold menu or power button and reset this little button at the back and it'll restarts in blue screen, it's in Chinese, so take photos of it and post it somewhere, maybe someone is willing to help or get someone who can read Chinese, it is really that simple, the bootloader will give you option to reload or hard reset, these devices are build this way.
Someone told me once that if you put something on SD card, it will start from SD card. There is this simple software called CECommand or TotalCommander, it's free, you can change it's name to whatever suits you, maybe you can rename it to your shell.exe and put it on SD and restart, people should know, here in this forum, how to hack them, using SD card
Another option: Harris Scarf is selling them for $129.00, buy one
and ask if you can return it if you are not happy with it.
Dump everything from it using DiskRW.exe, all the partitions one by one, zip them, one by one and upload them somewhere, one by one and I will look at them and maybe recreate rom for you.
It looks to me like there was something changed in registry and the device cannot start any more, so maybe you have to reset the registry to factory settings, when I changed my registry in Tevion 4301, I created extra Launch120 and put explorer there, in case of the failure, it would still load in explorer.
If someone deleted some files, then the unit won't star either,
you will need active sync to repair it.
When I was playing with main, I could access it using uBook and I opened this CEcommand with it and I was in windows, it was that easy.
I am sorry, I don't have it any more.
john
P.S. Australian HP IPAQ312 has got an option in Control Panel, to change USB settings as Storage device or Communication port, when you change it to Storage, then you can only see it as external storage on your PC.
Maybe it has got this settings as well and is set as Storage, that's why active sync doesn't work, I don't remember if I've ever connected it to PC, it was in February.
john

Hi guys,
I found the answer, look at the topic "Tevion freezes or loops while loading", the answer is straight under your noses.