PDA

View Full Version : eXplorist 500 won't start



GaryM
13th October 2007, 06:15 PM
Have a near new eXplorist 500 and quite satisfied until now. Used it yesterday and all ok but last night will not start up. Tried recharging battery but no change. Unit simply will not start up although buttons still beep. Help?????

GaryM
14th October 2007, 04:41 PM
My response to my call for help. Earlier today I tried recharging the battery again and hey presto the unit started to operate and is now nearly recharged. Did not do anything diferent but not complaining. It seems the battery was fully discharged so I will try and avoid that in future. Now I will see if it saved my new POI's. Once I get that organised I will see if I can make them available to others as there does not seem to be much from the Kimberley on the site. Cheers Gary

mlenser
14th October 2007, 05:02 PM
Hi Gary,
Good to hear that you resolved your problem with you eXplorist. I've only owned Garmin units myself so I have no clue about problems with Magellans. I am surprised that the GPS let the battery get fully discharged while being used, its more common when a near flat battery is left in the cupboard for a few months.
Any contribution to GPS Australia would be much appreciated I'm sure. Did you recently travel to the Kimberly's or are you planning a trip up that way? Its been 10 years since I was up that way, long before I owned a gps.

Best Regards
Mike.

GaryM
14th October 2007, 05:30 PM
Hi Mike, not quite sure of protocols for responding so hope this gets you. Appreciate your message and can only think that I over used the unit on the trip down from Kununurra - but that was only about 4 hours. I am currently working in Halls Creek as the Acting Shire CEO since July. Hope to be out before Xmas. Fantastic country and lots of good spots but have only had the GPS since September - so a novice. I need to get back to mark some POI's around Balgo, Lake Gregory etc. Also sorry I did not have it a couple of years ago while at Tom Price. Now I know of this forum I will try to contribute. Also have just returned from PNG and have a couple of original WW2 maps of the Lae campaign. Cheers Gary

GaryM
4th November 2007, 05:45 PM
Further to my original problem, it happened again last week. Just would not start up. My IT nephew suggested removing the battery to cause a "reset" - worked a treat. Still not sure what the cause of the problem is but if anyone has a similar difficulty try the "reset" option.