PDA

View Full Version : New Explorist400 firmware



arthurking83
14th December 2005, 03:54 PM
There is a new firmware version out for the Explorist 400.

There could be bugs in this firmware! Use with caution

Explorist firmware v 2.01 (http://www.magellangps.com/en/support/products/softwareupdates/eXplorist_400.asp)

Apparently there are no details on what has changed :confused:

But there is a THREAD (http://forums.groundspeak.com/GC/index.php?showtopic=116343&st=0&#entry1894898) at groundspeak that may enlighten us more

The firmware file is a windows executable, should be easy enough to update!

Pluto
14th December 2005, 04:20 PM
Have you looked at Next Destination's and/or Magellan's web sites? That's where the upgrade notes will be.

arthurking83
14th December 2005, 05:02 PM
Yep!

There is no description on Magellan's site about the firmware fixes/features!

NextDestination has no firmware download page AFAIK, and only provide a link to the Magellan firmware page.

ps. I have very little faith in the NextDestination website!

Even though the Explorist XL manual(pdf) has been available on the Magellan website for about 6 weeks, NextDestination are yet to update their site!

:confused:

arthurking83
16th December 2005, 07:45 PM
I just read a post, in a yahoo group, that says the new firmware could be buggy??

I don't have an expl400, so I can't verify (but my previous experience with Magellan firmware updates......... :rolleyes: )
I don't know if there is a way to backup/restore the older firmware?

The chap that posted reckons........


.....with errors sometimes as great as 300 yards (with 6 sats
tracking!) that persist for several minutes. There appears to also be a static
displacement about 100 feet to the east and almost that to the south that
seems to persist. The map sometimes fails to update while I'm driving unless I
rotate through the views on the menu. It also occasionally allows the cursor
to run off the screen without recentering the map.....

Good one Magellan!

J..
22nd December 2005, 06:29 PM
What kind of bugs does firmware updates aim to fix? My e600 runs fine as far as I can tell, I'd love it though if they could do something to make it load a little faster :rolleyes:

arthurking83
22nd December 2005, 07:33 PM
Oh! I forgot to re-reply/edit.

The dude that found the bugs, may have had the problem because he didn't reset his GPSr (Explorist400 only!!) AFTER he uploaded the firmware :confused:

Apparently it doesn't say so anywhere, but if you experience this problem you need to reset the GPSr again after the new firmware upload!

And yes, it's only for the Expl400, it apparently won't work on another explorist (someone's tried it).